You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 

87 lines
2.6 KiB

{
"name": "lolisafe",
"version": "3.0.0",
"description": "Blazing fast file uploader and awesome bunker written in node! 🚀",
"repository": {
"type": "git",
"url": "https://github.com/BobbyWibowo/lolisafe"
},
"bugs": {
"url": "https://github.com/BobbyWibowo/lolisafe/issues"
},
"engines": {
"node": ">=10.0.0"
},
"license": "MIT",
"scripts": {
"start": "node ./lolisafe.js",
"pm2": "pm2 start ./lolisafe.js",
"lint": "gulp lint",
"build": "gulp default",
"watch": "gulp watch",
"develop": "env NODE_ENV=development yarn watch",
"migrate": "node ./database/migration.js",
"bump-versions": "node ./scripts/bump-versions.js",
"cf-purge": "node ./scripts/cf-purge.js",
"clean-up": "node ./scripts/clean-up.js",
"delete-expired": "node ./scripts/delete-expired.js",
"rebuild-hashes": "node ./scripts/rebuild-hashes.js",
"thumbs": "node ./scripts/thumbs.js",
"pull": "git pull && yarn --production",
"stash": "git stash || true",
"stash-pop": "git stash pop || true",
"full-upgrade": "rm -f ./yarn.lock && yarn"
},
"dependencies": {
"bcrypt": "~5.0.0",
"blake3": "~2.1.4",
"body-parser": "~1.19.0",
"clamscan": "^1.3.3",
"content-disposition": "~0.5.3",
"express": "~4.17.1",
"express-rate-limit": "~5.2.3",
"fluent-ffmpeg": "~2.1.2",
"helmet": "~4.4.1",
"jszip": "~3.5.0",
"knex": "~0.21.17",
"multer": "~1.4.2",
"node-fetch": "~2.6.1",
"nunjucks": "~3.2.2",
"randomstring": "~1.1.5",
"readline": "~1.3.0",
"search-query-parser": "~1.5.5",
"serve-static": "git+https://git@github.com/BobbyWibowo/serve-static#02c26587b25a7156a89dc05b617fce0aa90cefb9",
"sharp": "~0.27.1",
"sqlite3": "5.0.0",
"systeminformation": "~5.0.8"
},
"devDependencies": {
"browserslist": "~4.16.3",
"bulma": "~0.9.2",
"cssnano": "~4.1.10",
"del": "~6.0.0",
"eslint": "~7.19.0",
"eslint-config-standard": "~16.0.2",
"eslint-plugin-compat": "~3.9.0",
"eslint-plugin-import": "~2.22.1",
"eslint-plugin-node": "~11.1.0",
"eslint-plugin-promise": "~4.2.1",
"fibers": "~5.0.0",
"gulp": "~4.0.2",
"gulp-buble": "~0.9.0",
"gulp-cli": "~2.3.0",
"gulp-dart-sass": "~1.0.2",
"gulp-eslint7": "~0.3.0",
"gulp-if": "~3.0.0",
"gulp-nodemon": "~2.5.0",
"gulp-postcss": "~9.0.0",
"gulp-replace": "~1.0.0",
"gulp-sourcemaps": "~3.0.0",
"gulp-stylelint": "~13.0.0",
"gulp-terser": "~2.0.1",
"postcss": "~8.2.4",
"postcss-preset-env": "~6.7.0",
"stylelint": "~13.9.0",
"stylelint-config-standard": "~20.0.0"
}
}